Este plugin não foi testado com as 3 últimas grandes versões do WordPress. Pode já não ser suportado e pode ter problemas de compatibilidade quando usado com versões mais recentes do WordPress.

PuppyFW

Descrição

This plugin allows you add options pages simply via Options Page Builder. It’s free but supports premium features: tab, group field, repeatable field, field dependencies. It’s powerful but lightweight and fast.

Beside built-in fields, PuppyFW also allows you can create your own fields easily.

Checkout the short video below to have a first look about this plugin:

More Information

Instalação

  1. Upload the plugin files to the /wp-content/plugins/puppyfw directory, or install the plugin through the WordPress plugins screen directly.
  2. Activate the plugin through the ‘Plugins’ screen in WordPress.
  3. Go to Options pages > Add New to add an options page.
  4. Follow the documentation for more detail.

Perguntas frequentes

Installation Instructions
  1. Upload the plugin files to the /wp-content/plugins/puppyfw directory, or install the plugin through the WordPress plugins screen directly.
  2. Activate the plugin through the ‘Plugins’ screen in WordPress.
  3. Go to Options pages > Add New to add an options page.
  4. Follow the documentation for more detail.
Does it support nested tabs

Yes, it supports multi-level nested tabs.

Can repeatable field woth with group, editor?

Yes, repeatable field can work with any fields.

Can group field be sortable and collapsible?

At the moment, it can’t. But they will be supported in the future.

Avaliações

Este plugin não tem avaliações.

Contribuidores e programadores

“PuppyFW” é software de código aberto. As seguintes pessoas contribuíram para este plugin:

Contribuidores

Traduza o “PuppyFW” para o seu idioma.

Interessado no desenvolvimento?

Browse the code, check out the SVN repository, or subscribe to the development log by RSS.

Registo de alterações

0.4.4

  • Fix missing removeRule() method in options page builder

0.4.3

  • Added alpha channel option for colorpicker field
  • Fix colorpicker attributes doesn’t work with WordPress 4.9

0.4.2

  • Fix field attributes doesn’t work
  • Fix image field doesn’t work when use URL
  • Fix slashes issue when save fields

0.4.1

  • Fix Vietnamese text encoding

0.4.0

  • Support media buttons in editor field (requires WordPress 4.9)
  • Added import/export feature for options page builder
  • Hook puppyfw_builder_assets
  • Show options page data in posts list table
  • Removed PUPPYFW_VERSION constant
  • Check the existing of function puppyfw() to load plugin instead of PUPPYFW_VERSION constant which be removed

0.3.0

  • First release