Suporte » Temas e templates » Compatibilidade de um tema com o Budypress

  • Olá, recentemente eu instalei o plugin Buddypress no meu blog, até aí correu tudo bem… o problema é que eu queria manter o tema que tenho agora (Collective da Theme Forest). Eu até já instalei o plugin BP compatibility que me parece ser bastante útil porque explica quais são os ficheiros que têm de ser editados mas mesmo assim eu não consigo fazer as modificações necessárias no HTML para que o alinhamento do Buddypress corresponda ao tema… Será que alguém me pode ajudar?

    Muito obrigado!

A visualizar 14 respostas - de 1 a 14 (de um total de 14)
  • Moderador Ze Fontainhas

    (@vanillalounge)

    Podes precisar um pouco mais quais são exactamente os problemas que estás a ter? Podes pôr aqui um link para o teu site?

    Bem, como já referi um dos problemas é o alinhamento mas também a barra lateral desaparece (aparece o erro: Parse error: syntax error, unexpected $end in /hermes/bosweb/web151/b1518/ipg.photoshopptcom/wp-content/themes/collective/sidebar.php on line 5) e a toolbar do Buddypress também desaparece… Aqui fica o link para o site: http://www.photoshoppt.com/atividade. O motivo porque o link aponta para a página “atividade” é porque eu decidi não associar o activity stream à homepage visto o meu site já ser “público” eu estava a tentar que estas modificações não afectassem a forma como os visitantes vêem o site, pelo menos, por enquanto. Por isso associei o activity stream à tal página “atividade”.

    Obrigado pela disponibilidade!

    Moderador Ze Fontainhas

    (@vanillalounge)

    Mistérios do faroeste… Hmmm, podes copiar e colar o conteúdo (código) completo desta página:

    /hermes/bosweb/web151/b1518/ipg.photoshopptcom/wp-content/themes/collective/activity/index.php

    no Pastie, para ver?

    Já colei o código no Pastie, deixo a seguir o link para código:
    http://pastie.org/4025451

    Moderador Ze Fontainhas

    (@vanillalounge)

    É um erro simples, falta-te um / no primeiro bloco de comentários.

    Aqui está a versão correcta.

    Obrigado pela ajuda. Realmente a minha falta de experiência com o PHP é bastante notável! Já corrigi o erro, mas ainda assim os problemas mantêm-se… Enfim, não há-de ser nada que não se resolva… vou “estudar” a situação e ver com mais atenção o que posso fazer. Obrigado

    Moderador Ze Fontainhas

    (@vanillalounge)

    Parece que tens un erro neste ficheiro (estão-me a parecer muitos erros para um tema normal…):

    /hermes/bosweb/web151/b1518/ipg.photoshopptcom/wp-content/themes/collective/sidebar.php

    Pastie, outra vez?

    Admito que não estava à espera de tanta ajuda aqui no fórum, fico contente por haver pessoas que se preocupam verdadeiramente com os utilizadores do WordPress (e que para além disso são bastante pacientes)! Bem, aqui fica o link para o código: http://pastie.org/4027975

    Moderador Ze Fontainhas

    (@vanillalounge)

    O que faz do WordPress o melhor CMS do mundo não é só o código, são as pessoas, também 🙂

    Tenho a confessar que estou um pouco intrigado… Esse código que mostras, está a dar erro porque o que ele está a tentar fazer é isto:

    “Se condição A for verdade ou condição B for verdade, então faz”… e não há nada a seguir ao “então faz” !

    De onde vem esse tema? Como já tinha mencionado antes, a (falta de) qualidade do código é surpreendente…

    Moderador Ze Fontainhas

    (@vanillalounge)

    My bad, o sidebar.php parece estar correcto. Tenho que olhar para o index.php outra vez 🙁

    Moderador Ze Fontainhas

    (@vanillalounge)

    Quais são as alterações que o BP Compatibility te diz para fazeres?

    O tema chama-se Collective e é da Theme Forest (http://themeforest.net/item/collective-community-wordpress-theme/123906).

    As alterações que o BP Compatibility diz para fazer ainda são umas quantas! Primeiro diz que tenho de modificar a estrutura HTML de alguns dos templates do Buddypress para corresponderem à estrutura do page.php ou index.php e depois diz que os templates que têm de ser alterados são:
    /activity/index.php
    /blogs/index.php
    /forums/index.php
    /groups/index.php
    /groups/create.php
    /groups/single/home.php
    /groups/single/plugins.php
    /members/index.php
    /members/single/home.php
    /members/single/plugins.php
    /members/single/settings/delete-account.php
    /members/single/settings/notifications.php
    /members/single/settings/general.php
    /registration/register.php
    /registration/activate.php

    Moderador Ze Fontainhas

    (@vanillalounge)

    Ok, tenho aqui umas dúvidas que não posso resolver, por não ter comprado o tema (e essa é a razão pela qual nem sempre é possível dar suporte a temas pagos aqui).

    A principal é de saber se o Collective precisa ou não do BP Compatibility, e se sim, saber se leste com atenção esta página com as instruções detalhadas.

    Agradecia que colocasses este problema no fórum de suporte do Collective (cujos tópicos, mais uma vez, eu não consigo ver por não ser cliente), e indicares aqui a resposta que te dão.

    Quanto ao facto de o Collective precisar do BP Compability não tenho a certeza mas penso que sim e penso que entendi as instruções (mas sinceramente também não posso garanti-lo).

    Mas então, eu vou colocar estas questões no forum de suporte do Collective e aguardar pela resposta.

    Agradeço toda a tua ajuda até agora.

A visualizar 14 respostas - de 1 a 14 (de um total de 14)
  • O tópico ‘Compatibilidade de um tema com o Budypress’ está fechado a novas respostas.