Suporte » Questões avançadas » Erro wp-admin

  • Resolvido Flasker

    (@flasker)


    Alguem sabe porque me esta a dar esses erros?

    Consigo aceder ao site mas não consigo aceder ao wp-admin nem o wp-login.php funciona.

    [17-Feb-2014 01:32:46] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 02:21:17] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 02:32:27] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 03:05:05] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 08:43:57] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 09:13:46] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 11:28:43] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 13:41:17] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/pluggable.php on line 896
    [17-Feb-2014 14:11:16] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 14:25:54] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 16:19:14] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/pluggable.php on line 896
    [17-Feb-2014 16:34:13] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/pluggable.php on line 896
    [17-Feb-2014 17:04:14] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/pluggable.php on line 896
    [17-Feb-2014 17:19:14] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8
    [17-Feb-2014 18:15:06] PHP Warning: Cannot modify header information – headers already sent by (output started at /home1/dformweb/public_html/aminhaourivesaria/site/wp-config.php:1) in /home1/dformweb/public_html/aminhaourivesaria/site/wp-includes/feed-rss2-comments.php on line 8

A visualizar 6 respostas - de 1 a 6 (de um total de 6)
  • Thread Starter Flasker

    (@flasker)

    O meu wp-config.php

    <?php
    /**

    * The base configurations of the WordPress.

    *

    * This file has the following configurations: MySQL settings, Table Prefix,

    * Secret Keys, WordPress Language, and ABSPATH. You can find more information

    * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing

    * wp-config.php} Codex page. You can get the MySQL settings from your web host.

    *

    * This file is used by the wp-config.php creation script during the

    * installation. You don’t have to use the web site, you can just copy this file

    * to “wp-config.php” and fill in the values.

    *

    * @package WordPress

    */

    // ** MySQL settings – You can get this info from your web host ** //

    /** The name of the database for WordPress */

    define(‘DB_NAME’, ‘teste’);

    /** MySQL database username */

    define(‘DB_USER’, ‘teste’);

    /** MySQL database password */

    define(‘DB_PASSWORD’, ‘teste’);
    /** MySQL hostname */

    define(‘DB_HOST’, ‘localhost’);

    /** O “Database Charset” a usar na criação das tabelas. */
    define(‘DB_CHARSET’, ‘utf8’);

    /** O “Database Collate type”. Se tem dúvidas não mude. */
    define(‘DB_COLLATE’, ”);

    /**#@+
    * Chaves Únicas de Autenticação.
    *
    * Mude para frases únicas e diferentes!
    * Pode gerar frases automáticamente em {@link https://api.wordpress.org/secret-key/1.1/salt/ Serviço de chaves secretas de WordPress.org}
    * Pode mudar estes valores em qualquer altura para invalidar todos os cookies existentes o que terá como resultado obrigar todos os utilizadores a voltarem a fazer login
    *
    * @since 2.6.0
    */
    define(‘AUTH_KEY’, ‘put your unique phrase here’);
    define(‘SECURE_AUTH_KEY’, ‘put your unique phrase here’);
    define(‘LOGGED_IN_KEY’, ‘put your unique phrase here’);
    define(‘NONCE_KEY’, ‘put your unique phrase here’);
    define(‘AUTH_SALT’, ‘put your unique phrase here’);
    define(‘SECURE_AUTH_SALT’, ‘put your unique phrase here’);
    define(‘LOGGED_IN_SALT’, ‘put your unique phrase here’);
    define(‘NONCE_SALT’, ‘put your unique phrase here’);

    /**#@-*/

    /**
    * Prefixo das tabelas de WordPress.
    *
    * Pode suportar múltiplas instalações numa só base de dados, ao dar a cada
    * instalação um prefixo único. Só algarismos, letras e underscores, por favor!
    */
    $table_prefix = ‘wp_’;

    /**
    * Idioma de Localização do WordPress, Inglês por omissão.
    *
    * Mude isto para localizar o WordPress. Um ficheiro MO correspondendo ao idioma
    * escolhido deverá existir na directoria wp-content/languages. Instale por exemplo
    * pt_PT.mo em wp-content/languages e defina WPLANG como ‘pt_PT’ para activar o
    * suporte para a língua portuguesa.
    */
    define(‘WPLANG’, ‘pt_PT’);

    /**
    * Para developers: WordPress em modo debugging.
    *
    * Mude isto para true para mostrar avisos enquanto estiver a testar.
    * É vivamente recomendado aos autores de temas e plugins usarem WP_DEBUG
    * no seu ambiente de desenvolvimento.
    */

    define(‘WP_DEBUG’, false);

    /* E é tudo. Pare de editar! Bom blogging!. */

    /** Caminho absoluto para a pasta do WordPress. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Define as variáveis do WordPress e ficheiros a incluir. */
    require_once(ABSPATH . ‘wp-settings.php’);

    O wp-config.php parece correcto, com excepção das partes que alteras-te de propósito, penso que esta também foi uma delas:

    define('AUTH_KEY', 'put your unique phrase here');
    define('SECURE_AUTH_KEY', 'put your unique phrase here');
    define('LOGGED_IN_KEY', 'put your unique phrase here');
    define('NONCE_KEY', 'put your unique phrase here');
    define('AUTH_SALT', 'put your unique phrase here');
    define('SECURE_AUTH_SALT', 'put your unique phrase here');
    define('LOGGED_IN_SALT', 'put your unique phrase here');
    define('NONCE_SALT', 'put your unique phrase here');

    É essencial colocares aqui as chaves geradas.
    Em relação ao erro, tens algum plugin instalado ou tema?

    Obrigado.

    Thread Starter Flasker

    (@flasker)

    Tinha os plugins instalados mas desactivei, o tema é o original que vêem com o WP

    Thread Starter Flasker

    (@flasker)

    Tinha os plugins instalados mas desactivei, o tema é o original que vêem com o WP

    Thread Starter Flasker

    (@flasker)

    Sera que esses erros pode ser problema mesmo de servidor ou o php ou o apache desactualizado.

    Teria de estar muito desactualizado para dar estes erros, qual é a versão que estás a utilizar?

    Já experimentas-te reinstalar o WordPress?

A visualizar 6 respostas - de 1 a 6 (de um total de 6)
  • O tópico ‘Erro wp-admin’ está fechado a novas respostas.