Suporte » Problemas no funcionamento » HTTP ERROR – Upload de imagens na Biblioteca

  • Resolvido robertocardoso

    (@robertocardoso)


    Olá,

    Toda vez que eu tento publicar uma imagem na biblioteca do WordPress, ocorrem as seguintes mensagens de erro:

    – HTTP Erro (quando utilizo o flash uploader)
    – Internal server error (quando utilizo o browser uploader)

    Isto vem causando grandes transtornos, pois não consigo publicar nenhuma imagem nos posts.

    Engraçado que no sábado a noite o erro veio à tona. No domingo cedo, estava funcionando normalmente sem que eu tenha realizado qualquer intervenção. No mesmo dia a tarde, o problema passou a persistir a partir de então.

    Já tentei resolver de várias maneiras, mas não consegui. O cache do browser foi apagado, o .htaccess alterado, todos os plugins desativados, a versão do WordPress foi atualizada para a 3.4.1 e nenhuma das intervenções deu certo.

    Alguém saberia dizer o que seria e como resolver o problema?

    Obrigado

A visualizar 14 respostas - de 1 a 14 (de um total de 14)
  • Tenho o mesmo problema.
    Alguém ajuda…?

    Olá Rui,

    O problema no meu caso estava com o plugin de Cache. A solução foi a seguinte:

    – Apagar o plugin de cache
    – Apagar todos os arquivos do navegador (historico, cache, etc)
    – Permissionar a pasta wp-content/uploads para 777

    Abraços

    Olá estou com o mesmo problema:
    http://br.forums.wordpress.org/topic/nao-consigo-mais-subir-imagens-no-wp?replies=7#post-42545

    Como procedo pra efetuar a sua solução Roberto?
    Não tenho plugin de cache instalado e minhas pastas já estão com permissão 777

    Olá Allkita,

    Realmente esses erros tiram o nosso sono. Com toda a certeza é um detalhe besta que está dando o seu erro. Para achar esse detalhe é como uma agulha no palheiro.

    No meu caso era o problema com um plugin de cache. No seu caso, como o upload das imagens estava funcionando perfeitamente antes, tente levantar alguma coisa que você tenha feito neste meio tempo, talvez um plugin novo instalado.

    Uma coisa que funcionou pra mim foi o seguinte. Eu estava dando permissões 777 nas pastas por um programa de FTP e só depois descobri que isto não estava funcionando. Meu site também estava no UolHost. A solução foi fazer o novo permissionamento dentro do próprio painel de controle do UolHost. Daí sim funcionou.

    Por onde você está fazendo o permissionamento?

    Abraços,

    Roberto

    Outro caminho é você criar um novo arquivo .htaccess com o seguinte conteúdo:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Faça isso dentro do próprio painel do UolHost no gerenciador de arquivos. Coloque um dentro da pasta raiz do seu site (dentro da pasta PUBLIC_HTML em servidor linux ou na pasta WEB em servidor windows) e outro dentro da pasta WP-CONTENT>UPLOADS.

    Espero que funcione.

    Se não funcionar, pesquise na web outros conteúdos possíveis pra você configurar seu arquivo .htaccess permitindo o uploads de imagens.

    Abraços,

    Roberto

    Então…eu não instalei nenhum plugin, nem nada…a unica coisa que houve de diferente é q meu Flash Player do PC se atualizou….mas tentei subir as imagens sem usar o flash no WP e mesmo assim não foi!

    Inclusive nem pode ser algo do tema (como plugins etc) pq eu instalei Outro WP numa pasta de Teste e mesmo neste WP de teste não dá pra subir nenhuma imagem!!!

    Já vi as pastas diretamente no UOLhost e estão todas com permissão de leitura e escrita…

    inclusive as sub-pastas (/wp-content/uploads/2013/06)

    MeoDeos eu vou ter um treco ja ja…

    Alguém me ajuda!!!!!!!!!!!!!

    OI Roberto vou tentar sua dica do .htaccess

    Mas só uma dúvida…meu WP está instalado numa sub-pasta chamada “novo” preciso mudar algum endereço aí no arquivo???

    http://www.meusite.com.br/novo

    Tente configurar o arquivo .htaccess. Veja no meu post acima!

    Creio que não precisa. No gerenciador de arquivos dentro do UolHost, procure pelo arquivo .htaccess e clique no BOTÃO EDITAR ARQUIVO na coluna AÇÕES. Esse botão é representado por um papel e um lápis por cima:

    1. Clique no botão editar
    2. Copie e cole o conteúdo abaixo
    3. Clique no botão salvar arquivo
    4. Apague todos os dados do seu navegador (histórico, cache, etc)
    5. Reze para funcionar! =)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    rs….na hospedagem do UOL não tem esse arquivo….vou criar um do zero.

    Oi Roberto…tb não funcionou mexendo no htaccess =(

    A solução é investigar e realizar ações de tentativa e erro. Tente desabilitar todos os plugins pra ver se há algum conflito.

    Já desativei td e nada…afff

    Acho q vou sugerir pro cliente trocar de hospedagem..pq nada faz sentido viu!!! affff q merda!

    A versão do WordPress está atualizada?
    A versão do tema está atualizada?
    Já tentou desativar o tema atual? Utilize o tema padrão e veja se funciona.

A visualizar 14 respostas - de 1 a 14 (de um total de 14)
  • O tópico ‘HTTP ERROR – Upload de imagens na Biblioteca’ está fechado a novas respostas.