Suporte » Problemas no funcionamento » Página de login ao Dashboard do WP em branco!?

A visualizar 10 respostas - de 1 a 10 (de um total de 10)
  • Provavelmente alguma função que não existe ou algum ficheiro em falta… no teu wp-blog-header.php coloca temporariamente estas linhas:

    ini_set('display_errors','on');
    error_reporting(E_ALL);

    Depois diz-me o que apareceu sff.

    Nada de nada!

    Fiz as alterações, fui à homepage e aparece tudo normal, como aparecia antes. Assim que vou ao Admin WP aparece de novo a página em branco.

    Faz o download do WordPress novamente e transfere os ficheiros, se o erro persistir, remove o tema que estas a usar, se depois de removeres o tema, funcionar, teremos de saber qual o tema que estas a usar e quais as alterações que fizeste.

    O problema é quase de certeza um erro de sintaxe.

    Boa noite,

    Sim, parece que o problema está no tema.
    Agora a questão é: Porque é que funcionou até agora e de repente, sem qualquer actualização deixou de funcionar?
    Só se o host provider fez modificações sem avisar em algum lado!

    Parece-me que o tema é antigo demais para a versão de WP que tinha na altura: a 2.1 creio.

    Já tenho novo hosting, já convenci a pessoa a mudar de tema.
    O problema é que não tenho acesso ao Dashboard do WP por isso não posso exportar posts e etc para xml.

    Como ainda tenho acesso FTP, fiz um backup da BD MySQL.
    Criei nova BD no novo host, e agora desde a nova BD importei do backup.
    Problema: Todos os links têm o endereço do site antigo 🙁
    Como contorno isto?
    Obrigado pela paciência a ler o longo texto.

    Esta nova versão ( felizmente ) removeu muito código antigo para bem da performance do WordPress que estava a perder bastante com isso.

    Quanto aos textos, são o “the_content()”? caso seja do conteúdo o mais simples seria uma instrução MySQL simples

    UPDATE O-TEU-PREFIXO_posts set post_content=REPLACE('http://o-teu-ANTIGO-dominio.com','http://o-teu-NOVO-dominio.com',post_content)

    Matavas logo todos os coelhos 😛

    Viva,

    Obrigado, mas pode dar-me uma ajuda, mais especificamente com essa instrução MySQL ?

    Tenho o backup da bd antiga. Tenho de importar a antiga dentro de uma nova e depois dou exactamente que instrução, para mudar o link do alojamento antigo para o novo?
    Obrigado.

    Sim, o mais simples seria ires ao teu PHPMyAdmin e correres essa instrução 🙂 trocando “O-TEU-PREFIXO” pelo prefixo que escolheste para a base de dados, e assim sucessivamente.

    Exemplo: prefixo das tabelas é wp_, site antigo: http://siteantigo.com e site novo http://sitenovo.com

    a instrução seria “UPDATE wp_posts set post_content=REPLACE(‘http://siteantigo.com’,’http://sitenovo.com’,post_content)”

    Depois rectificas o config e já está 🙂

    ok, executei essa instrução e deu mensagem de ok, no entanto, quando vou ao wp-admin.php insiro o user e pass mas na descrição do link de login aparece o endereço antigo ainda 🙁

    Mais alguma ideia, por favor?
    Obrigado

    não fizeste a ultima parte: “Depois rectificas o config” ou seja, opções -> geral

    Viva,

    Para resolver o problema acima do link aparecer com o servidor antigo resolvi da seguinte forma:

    Acrescentei as duas linhas a seguir ao wp-config.php

    define(‘WP_HOME’,’http://cantinhodaceli.megafone.cc’);
    define(‘WP_SITEURL’,’http://cantinhodaceli.megafone.cc’);

    Agora ainda tenho um problema quanto ao resto!

A visualizar 10 respostas - de 1 a 10 (de um total de 10)
  • O tópico ‘Página de login ao Dashboard do WP em branco!?’ está fechado a novas respostas.