Suporte » Instalação » Problema com permalinks

  • Boa tarde! este é meu primeiro post neste fórum, gostaria de esclarecimentos dos amigos sobre o funcionamento do permalinks.

    Meu âmbiente: máquina local opensuse 11.4, servidor apache2 versão 2.2.17 com mod_rewrite habilitado.

    Já segui e tentei configurar o permalink conforme documentações disponibilizadas na documentação oficial e tbm em outras fontes, mas ainda não obtive sucesso.

    O arquito .htaccess está configurado e com acesso total 777, conforme mostra seu conteúdo:

    #cat .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    A estrutura personalizada está setada com as variáveis: /%category%/%postname%/

    Mas os posts só aparecem na página principal, algums sugestão?

A visualizar 3 respostas - de 16 a 18 (de um total de 18)
  • O IIS não tem Rewrite ( excepto a ultima versão, caso a tenhas, envia-me o ficheiro de configuração de rewrite sff ).
    O IIS não lê instruções de .htacess ou seja, muito provavelmente vais ter de voltar à estrutura original de “?id=XXXXX”

    Existe alguma razão para estares a usar servidores “Windows”?
    Opinião pessoal: Windows + Servidores são duas palavras que não se conjugam bem.

    Vou verificar a versão do IIS, a razão de usá-lo, é que me foi oferecido gratuitamente, não pago pelo serviço de hospedagem.

    Pessoalmente, prefiro linux, o que uso localmente.

    Abs!

    O serviço de hospedagem respondeu, que o server deles não tem rewrite, portanto, a questão se encerra no tocante ao servidor web.

    Mas o problema continua no servidor local, na minha máquina.

    Obrigado pela ajuda!

    Abs!

A visualizar 3 respostas - de 16 a 18 (de um total de 18)
  • O tópico ‘Problema com permalinks’ está fechado a novas respostas.