Suporte » Problemas no funcionamento » Problemas com barra de funções – WP 3.5

  • Resolvido entropiabr

    (@entropiabr)


    Caros, boa noite! Ao menos aqui do Brasil.
    Atualizei o WordPress 3.5 em alguns dos meus websites, e até agora pelo menos dois demonstraram um tipo de problema na barra lateral esquerda, onde administramos o CMS.
    Trabalho com ela reduzida, visualizando apenas os ícones. O fato é que após atualizar a versão não consigo acessar o menu contextual ou subcategorias, nem tirar o menu do modo reduzido…
    Estão passando por situação similar por aí? Como fazemos para corrigir isso?

A visualizar 15 respostas - de 1 a 15 (de um total de 19)
  • [removido, por favor não duplique tópicos nem desvie os existentes]

    Moderador Ze Fontainhas

    (@vanillalounge)

    @entropiabr: o primeiro passo é sempre limpar cache e cookies do seu navegador, sair da sessão e voltar a iniciar. Se mesmo assim não funcionar, verifique se não se trata de algum ero de Javascript: http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Bom dia, ao menos daqui do Brasil!
    Com relação ao cache e cookies, rodei o CCleaner e conectei novamente, e o formato da barra persiste… Destivei também todos os plugins, limpei tudo novamente e conectei, e nada… E o mais estranho é que acontece com alguns sites e com outros não! Tenho dois sites onde ocorreu esse problema e estou atualizando os outros gradativamente, para que possa monitorar e reportar as falhas. Creio que tenha algo a ver com o tema, mas não posso simplesmente desabilitar os temas ou trocar, dos sites que estão apresentando essa falha!

    Moderador Ze Fontainhas

    (@vanillalounge)

    Este plugin permite-te testar temas sem alterar o tema de produção:

    http://wordpress.org/extend/plugins/theme-test-drive/

    Olá!

    Também estou tendo problemas com a última atualização – 3,5. Já testei em 3 navegadores diferentes, 2 PCs diferentes e 2 redes diferentes.

    Os problemas que eu detectei agora são os seguintes:

    1) Não consigo editar usando a aba “Texto”, apenas “Visual”;

    2) Não consigo abrir/editar widgets nem arastar novos para as barras laterais.

    Nos sites onde ainda não fia a atualização está tudo certo.

    Pois é! O pior é que está variando de um site para o outro… Tive que restaurar a versão anterior em dois ou três sites já!
    E para mim tb notei problemas similares aos citados por você @jluizg!
    – Menu esquerdo se colapsado não abre;
    – Modificação dos menus do WP não funciona;

    Enfim, parece algum tipo de incompatibilidade no javascript, pois essas funções normalmente estão lá!
    Tentei também fazer o diagnóstico de erros do javascript e não detectei nada. E não tem relação direta com o tema pois varia! Chequei todos os plugins e desativei um tema de um site offline, deixando o Twenty Twelve e ainda assim os erros persistiam! É alguma falha da versão mesmo…

    Rui Santos

    (@ruisantosliketomovecom)

    Viva!

    Antes de mais gostaria de informar que se trata do meu primeiro post no WordPress, ferramenta que ando a recentemente investigar para lançar 2 websites.
    Dado que ainda estou em versão de testes, atualizei para aq versão 3.5 “à maluca” e verifiquei que entre outas coisas, no Widgets deixei de poder adicionar ou configurar Widget pela via normal, apenas pelo “accessibility mode” e mesmo por aqui sempre que edito um determinado WIDGET ele não carrega por defeito a sidebar respetiva, o que se provoca o seu desaparecimento se não voltamos a indicar.

    Já experimentei com o Chorme e com o FireFox, ambos na ultima versão.

    Sabes como resolver, ou trata-se de um problema de versão?

    Obrigado.

    Olá Rui, e bem vindo!
    Até onde pude notar é um problema da versão 3.5 e relacionado ao javascript. Não consegui contornar o problema, por isso nos sites onde tenho mais movimentação estou retornando a versão anterior… Ao menos até conseguirmos detectar e corrigir o problema!
    Tenho feito um backup geral do WP antes de atualizar e, se necessário, subo os arquivos antigos novamente.

    Pessoal, notei outra coisa em relação a atualização! Mesmo nos sites onde está funcionando normalmente a versão 3.5, ainda tem alguns detalhes.
    Chequem em sua inclusão de mídia se, ao preencher o campo “Título” o script de vocês salva a informação? Aqui nos sites que atualizei ele não grava na inclusão. Tenho que editar a imagem depois e incluir novamente o campo “Título”. Isso com certeza tem relação com o javascript como todo o resto. Sinto muito se não tenho sido de grande valia para resolver as pendências, mas estou ao menos tentando apontar onde estão as falhas para avaliação por pessoas mais competentes.

    Rui Santos

    (@ruisantosliketomovecom)

    Obrigado Entropiabr!!!

    Estive a fazer algum troubleshotting e verifiquei que o meu problema de não conseguir mexer nem arrastar se deve THEME que tenho instalado pois noutro site que tenho funciona correctamente. Neste website fiz uma instalação de raiz e fui adicionando os temas, plugins etc. e assim que adicionei o THEME o DASHBOARD de widgets deixou de funcionar corretamente.

    Para informação o THEME que utilizo é o SportPress 2.0 da SMthemes.

    Pois é Rui, pra mim não funcionou… Refiz a atualização do WP para o 3.5 e depois atualizei o tema, que é o Appointment da Templatic e ainda assim não normalizou. Depois alterei o tema para atualizado o Twenty Twelve e não normalizou… Limpei o cache e tudo o mais, mas nada adiantou!

    Rui Santos

    (@ruisantosliketomovecom)

    Viva Entropiabr,

    Já resolvi o problema utilizando o mesmo tema, segundo as informações do criador.

    No meu caso consistia em adicionar o seguinte código:
    define('CONCATENATE_SCRIPTS', false );

    no ficheiro wp-config.php, acima da linha:

    require_once(ABSPATH . 'wp-settings.php');

    Sem a certeza que no teu caso funcione, mas não custa nada experimentar 😉

    Boa sorte.

    Perfeito Rui! Aqui funcionou.

    Ficou assim:

    /* Isto é tudo, pode parar de editar! :) */
    
    /** Caminho absoluto para o diretório WordPress. */
    define('CONCATENATE_SCRIPTS', false );
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Configura as variáveis do WordPress e arquivos inclusos. */
    require_once(ABSPATH . 'wp-settings.php');

    Muito obrigado mesmo cara!

    Rui, muito obrigado pela dica.

    Ontem fiz a primeira alteração:

    define('CONCATENATE_SCRIPTS', false );

    e resolveu a parte de editar post em modo “Texto” (a aba texto foi liberada).

    Agora vou testar o restante e depois venho dizer o que aconteceu.

    Voltei…

    A única coisa que resolveu foi a questão de edição do post, conforme já comentei.

    Continuo não podendo editar nem criar novos Widgets. Sequer clicar e arrastar eu consigo.

    Esqueci de comentar que também não consigo responder comentários.

    Quando será que isso será resolvido?

A visualizar 15 respostas - de 1 a 15 (de um total de 19)
  • O tópico ‘Problemas com barra de funções – WP 3.5’ está fechado a novas respostas.