Suporte » Instalação » Tudo desde o início

  • Resolvido alecap

    (@alecap)


    Olá.
    Já procurei alguém tão ignorante como eu. Mas embora sejam várias as pessoas a afirmarem isso, sabem sempre muito mais que eu. :-\

    Vou começar do início: Tenho um Mac sistema 10.6.8.
    Fiz Download da última versão do wordpress (dá para mac, certo?)
    Fiz download do MAMP (como me indicaram)
    Vou comprar alojamento e domínio (ainda não comprei, mas já escolhi)
    E agora?

    Trabalho em design, é a única aproximação que tenho com sites 🙁

    Quando abro a pasta do wordpress aparecem uma série de ficheiros todos com extensões que para mim são ininteligíveis.

    Eu sei que são muitas questões no mesmo tópico, mas pelo menos, como abrir o wordpress, instalar um tema e nessa altura eu volto a perguntar ou procurar o que necessito.

    OBRIGADA mesmo por qualquer resposta
    Alexandra

A visualizar 14 respostas - de 1 a 14 (de um total de 14)
  • Olá:

    Alexandra, estás a misturar ligeiramente as coisas… a ver:

    • O WordPress corre independentemente do sistema operativo
    • O MAMP integra um conjunto de ferramentas para correr, não só, mas também o WordPress
    • Se pensas em contratar alojamento e comprar um domínio, para que é que queres uma instalação local?

    Esta ultima questão é retórica… pois efetivamente deverias fazer uma instalação local, no teu mac, para cometeres todos os erros e mais alguns, antes de avançar para o modo live.

    Experimenta ver o tutorial no codex aqui.

    Se ainda assim restarem dúvida, apita.

    obrigada Pereirinha 🙂
    como vês não percebo nada. Enfim, já comprei o alojamento e o domínio, se calhar cedo demais… certo. Mas já está!
    Vou espreitar o link que deixaste a ver se me ilumina.
    Obrigada mais uma vez. Mais alguma coisa volto a este tópico.

    bom dia,
    peço desculpa novamente.
    O MAMP foi perfeito. O WordPress, quando abro o wp-admin/install.php não funciona no browser, no help do install diz para colocar manualmente a informação da base de dados, se não funcionar no browser, mas não sei onde colocar isto:

    “database name: wordpress
    database host/server: localhost
    database user: root
    database password: root”

    🙁
    obrigada

    Olá Alexandra:

    Onde colocaste a pasta do WordPress, consegues dizer?

    Ela deve estar no local de serviço [document root] definido no MAMP, que por defeito é em /Applications/MAMP/htdocs/. Cria uma pasta com ‘nome de pasta da instalação do WordPress*’ e coloca lá o WordPress.

    Depois, no safari ou outro browser, acede a http://localhost/’nome de pasta da instalação do WordPress*’… se eventualmente tiveres problemas, experimenta http://localhost:8888/’nome de pasta da instalação do WordPress*’

    * por exemplo: alecap

    Vê lá se já te orientas.

    Olá.

    Eu acho que vou parar de chatear um bocado. Começo a sentir-me incomodativa. Vou pesquisar por outro lado e um dia destes volto 🙂

    Tinha colocado na pasta Documents/Sites/(ficheiros do wordpress)
    Mas já pus onde disseste. e quando faço localhost:8888/sites ou dá-me o 404 not found 🙁
    Mas fazendo o localhost:8889/sites já me faz download duma mensagem (J
    5.5.25y&L/FQDBˇ˜Ä[$A[&K’|`K8rmysql_native_password!ˇÑ#08S01Got packets out of order)
    Usei tanto o safari como o chrome.

    Devo estar a ver e/ou a fazer alguma coisa mal. Vou recomeçar o computador e refazer a parte do wordpress.

    Não devemos estar muito longe da solução… não desesperes já. 🙂

    Atenção que o nome das pastas é case sensitive, isto é, “Sites” não é a mesma coisa que “sites”… verifica isso.

    Entretanto, tenta colocar um link para uma imagem do teu finder contendo a pasta em questão, assim como o print screen do safari ou chrome.

    Em alternativa, e se não for indiscrição, de onde és?

    já deu e já deixou de dar.
    o servidor MySQL no MAMP não fica activo, não sei porquê.

    sou de almada

    Estamos no bom caminho…

    Já tive um problema semelhante ao teu… e acredita que me vi à nora para perceber o que se passava. Estou em crer que o MySQL do MAMP não arranca porque há uma outra instância a correr. O que poderás fazer, é matar a aplicação no Monitor de Atividade do MAC. Procura os processos MySQL e termina-os todos. Depois tenta ligar o MAMP… estou em crer que resolverás o problema.

    Sou de Gaia, por isso, é impossível ajudar-te presencialmente… mas não vai ser preciso.

    Olha não sei o que se passa. o MySQL já dá, mas o localhost voltou a não dar 🙁
    Obrigada.
    Hoje já não posso mais. Amanhã volto a tentar. Se quiseres dar um email para ser mais fácil falar, óptimo, senão encontramo-nos por aqui 🙂
    obrigada por tudo até agora.

    Olá Alexandra.

    Só agora me foi possível voltar cá.
    Quando dizes que o localhost voltou a não dar, o que é que isso quer dizer?

    Experimenta desligar os serviços do MAMP, desligar a máquina. Quando ligares, tenta ligar tudo novamente.

    Olá de novo.
    Continua a não funcionar nada. 🙁

    o que eu faço:
    abro o MAMP, activo os servidores, abre a start page do MAMP online.
    Vou a phpMyAdmin -> databases -> create database -> wordpressaladina4 (já vou na 4 porque como nunca funciona crio outra para ver se dá)

    uso o link que tu deste: localhost:8888/Sites
    (esta página sites está em: MAC HD/Applications/MAMP/htdocs/Sites)

    RESULTADO:
    Not Found

    The requested URL /Sites was not found on this server.

    O que eu acho estranho é que já deu, mas infelizmente bloqueei na parte do nome e pass do MySQL (não me lembrei que podia ser a do computador).
    Recomecei de novo e nunca mais deu :’-(

    Já não sei o que fazer… acho que vou desistir e vou para outra plataforma qq online, porque toda a gente me aconselha o wordpress, mas se é assim tão complicada a instalação… estou nisto há uns dias e ainda nem consegui começar a criar a página, que é o que eu quero fazer 😀

    Desculpa o testamento. Estou desanimada.

    Moderador Ze Fontainhas

    (@vanillalounge)

    O problema não tem a ver com o WordPress em si, mas sim com o MAMP… que o que faz é reproduzir um ambiente de servidor no teu Mac.

    A tua versão de MAMP é qual, normal ou Pro? Podes mostrar imagens do painel de preferências, i.e:

    http://documentation.mamp.info/en/mamp/preferences/start-stop
    http://documentation.mamp.info/en/mamp/preferences/ports
    http://documentation.mamp.info/en/mamp/preferences/php
    http://documentation.mamp.info/en/mamp/preferences/apache

    Quando digo que o problema não é do WordPress, deixa-me ilustrar que se fores a tentar com Drupal ou Joomla, o problema mantém-se. Enquanto o MAMP não estiver a funcionar, nem WordPress, nem Drupal, nem Joomla, nem nada que precise de Apache, PHP e MySQL vai funcionar.

    Olá Alexandra:

    O Zé tem razão. O problema está no MAMP e não no WordPress. Há qualquer coisa que está a falhar na tua configuração de base.

    Contacta-me pelo email do google com o meu ultimo nome ou com o primeiro e ultimo. Tentamos por outro meio a ajuda 😉

    Olá Zé, Olá Pereirinha,

    OBRIGADA.

    à falta de conseguir fazer upload dos print screens aqui, escrevo:

    imagem 1 – o 1º e o 3º não estão check (não me parece que seja por aí, mas já pus igual)
    imagem 2 – não pus as ports com default para não ter de pôr pass, mas já experimentei e acontece-me o mesmo. (já pus, de qualquer modo, para ficar igual ao teu)
    imagem 3 – PHP version 5.4.4 (tenho a última versão do MAMP, a outra hipótese que ele me dá é o 5.2.17) – Cache igual
    imagem 4 – /Applications/MAMP/htdocs/Sites (que é exactamente onde está, com os caps certos)

    os servers apache e MySQL estão os 2 activos.

    Depois disto tudo tenho experimentado 2 coisas:
    • Ou faço http://localhost:8888/htdocs/Sites (se tiver a port assim)
    ou http://localhost/htdocs/Sites (se tiver a port como dizes)
    e dá o tal erro NOT FOUND que descrevi em cima.

    • Ou vou correr os “famosos 5 minutes install” link que retiro do read me da pasta do wordpress e não acontece nada, ou melhor, o browser abre uma página com código.

A visualizar 14 respostas - de 1 a 14 (de um total de 14)
  • O tópico ‘Tudo desde o início’ está fechado a novas respostas.